Familypedia
Advertisement
Forums: Index > Help desk > Problem with Special : Ask



Early problem fixed[]

Copy of message I've just sent to Contact Wikia:


This appeared on the Yugioh Wiki when I clicked "Further results" at the bottom of a table, and I thought it was nothing I should be concerned about. But now I've got it on Familypedia, where we were not getting that problem before:

Permission error Special page

You are not allowed to execute the action you have requested.

Return to Family History and Genealogy Wiki.


The URL says http://familypedia.wikia.com/wiki/Special:Ask/-5B-5BDeath-20year::1880-5D-5D/-3FFather/-3FMother/-3FAge-20at-20death


I've just got the same result when trying to use Special:Ask in the title of this forum.

I was wanting to find which Familypedia people died in 1880, a rather basic search. Anyone else get the same when trying to find more info in a table? --- Robin Patterson (Talk to me) 06:15, March 15, 2011 (UTC)

This was a bug that has been fixed. In other news, we're going to try a technical backend change to see if it A) fixes the form issue on this site and B) just improves overall query improvement. The backend change is putting the SMW-related tables on its own database cluster. This should alleviate database memory usage. --daNASCAT WikiaStaff.png (help forum | blog) 21:00, March 15, 2011 (UTC)


Thanks, Tim. My "Contact" message received this reply (12 hours ago):

Changed in the newer versions of SMW, you now need the smwallowaskpage right to use Special:Ask. This has been corrected in the code last week, and will be going live with this week's release (sometime today/tomorrow)

-- Regards,

Chris "Uberfuzzy" Stafford, Wikia Community Support Team


--- Robin Patterson (Talk to me) 23:24, March 15, 2011 (UTC)

Images[]

This conversation may be of interest now. We used to have images on our tree pages. Maybe we could try again?


Hi, maybe this can help: https://sandbox.semantic-mediawiki.org/wiki/Issue/2009

Em ter, 22 de dez de 2020 16:53, Jacob Vos <jacobvos@impronotion.nl> escreveu:

Hi,

I have the category 'Thing', with form field 'Picture', with the semantic property 'ThingHasPicture'. Input type = 'Text', parameters 'uploadable, image preview', semantic property type = 'text'. All configured via Page Schemas.

I changed the Thing template to show the image, as follows (which works):

[[file:{{{Picture}}}|thumb|{{{Picture}}}]].

Now I want to have an #ask query, and one column showing the image (as thumbnail). So I tried: {{#ask: [[Category:Thing]] | ?Name | ?ThingHasPicture }}

However, this doesn't work. What should I do?


Kind regards, Jacob Vos

  _______________________________________________
   Semediawiki-user mailing list
   Semediawiki-user@lists.sourceforge.net
   https://lists.sourceforge.net/lists/listinfo/semediawiki-user

--- Robin Patterson (Talk) 00:39, December 23, 2020 (UTC)

Well, he has to use his "Thing" template to display the result of the query. Thurstan (talk) 03:30, December 23, 2020 (UTC)


Here, for those of you who don't subscribe to that mailing list, is the latest posting in that conversation:

Hi Jacob
I have just got it working on the SMW Sandbox. It is as I thought, yesterday I was doing it from memory. But you can see it working in the sandbox. The initial page can be found at

https://sandbox.semantic-mediawiki.org/wiki/20201224_image_call

This is then called in a #ask query on this page

https://sandbox.semantic-mediawiki.org/wiki/20201224_Picture_call

I hope that helps.

Gary

Code for the image page is :

An image taken in Regensburg in Germany, taken during the Semantic MediaWiki Conference 2018.
[[Fichier:Regensburg.jpg|néant|vignette|600x600px|this is a test image]]

{{#set:
Has country=Germany
|Picture=[[Fichier:Regensburg.jpg|néant|vignette|300x300px|this is a test image]]
|Has city=Regensburg
}}

[[Category:Category 20201224]]

Code for that second link is :

{{#ask:
[[Category:Category 20201224]]
[[Has country::Germany]]
|?Has city=City
|?Picture=Picture
|format=table
}}

And it looks like this:

Smw20201224.png

Some of our pages already do that sort of thing. I want us to be able to do it again on tree pages. Charlemagne/tree used to look great, a good example to show Familypedia off. --- Robin Patterson (Talk) 03:42, December 24, 2020 (UTC)

Advertisement